VFS not writable in VFS writable package

Configurating App-V Client components

Moderators: kirk, jur, kkaminsk

Post Reply
Jsdejong
Still installing locally
Posts: 2
Joined: Wed Jan 18, 2017 10:21 pm

VFS not writable in VFS writable package

Post by Jsdejong » Thu Apr 06, 2017 4:50 pm

We encoutered some problems in our Full Infrastructure Citrix environment lately.

Situation:
Citrix VDI Agent 7.9
Citrix PVS 7.9 (Cache in memory)
Windows 2012R2-x64
Appv Client 5.1 HF7
Package deployment: user published

We have a couple of packages which need to write into the VFS; so the VFS Writable flag is set on those packages.
The packages work perfectly on our test environment and on the production environment. However, on some servers the packages do not work fine: VFS is not writable on those servers.
Strange thing is, those servers run on the same PVS Vdisk.

I created a test package, which only contains a placeholder file and the VFS Writable flag.
When I open a CMD prompt in the virtual environment on a faulty server, go to the VFS location (C:\Program Files (x86)\Winvision_VFSWritableTest_1.0_NL_1.1.1) and create a file or folder, I receive an Access Denied error. When I do the same on a correct server, the file or folder is being created and the actual file/folder resides on the %LOCALLAPPDATA%\Microsoft\AppV\Client\VFS\<GUID>\ProgramFilesX86\Winvision_VFSWritableTest_1.0_NL_1.1.1

When viewing the procmon on both servers, I see different things.
On the correct server it checks if the file/folder exists in the the Programdata\App-V\<GUID>\ProgramFilesX86\VFS\ProgramFilesx86\Winvision_VFSWritableTest_1.0_NL_1.1.1 folder, gives a Name not Found message, and redirects to %LOCALLAPPDATA%\Microsoft\AppV\Client\VFS\<GUID>\ProgramFilesX86\Winvision_VFSWritableTest_1.0_NL_1.1.1, as it should.
Procmon_Correct_Server.png
Procmon on good server
Procmon_Correct_Server.png (156.47 KiB) Viewed 432 times
On the faulty server(s) it checks if the file/folder exists in the Programdata\App-V\<GUID>\ProgramFilesX86\VFS\ProgramFilesx86\Winvision_VFSWritableTest_1.0_NL_1.1.1 folder, gives an Access Denied message, and stops (doesn't redirect to the LOCALAPPDATA folder).
Procmon_Faulty_Server.png
Procmon on faulty server
Procmon_Faulty_Server.png (91.09 KiB) Viewed 432 times
It seems the Appv client isn't looking at the LOCALAPPDATA information at all.

This issue effects all users on the faulty machine. The machines are all using the same VDISK. Eventviewer doesn't show anything usefull so far.

I created a script, which starts on login which tries to write to VFS in this test package, and create logging of it fails; this to get a image on how many servers this issue exists. This issue exists on 6 of a couple of hundred machines. Strange thing; on one server, which had the issue, started working again.

Anyone had the same experience? Or some clue where to look at to fix this issue?

stuh
Still installing locally
Posts: 1
Joined: Fri Nov 24, 2017 11:07 am

Re: VFS not writable in VFS writable package

Post by stuh » Fri Nov 24, 2017 11:21 am

Hi,

Did you ever find a resolution to this?
FYI, I'm in a XA6.5 environment on a mix of physical and virtual machines and experiencing similar issues.

The common element is AppV 5.1 HF7, which we've just started rolling out to replace AppV 5.0.

Apps are seemingly randomly working for some users on some servers, and then not working, all around VFS access.

Thanks,

StuH

jur
Guru
Posts: 524
Joined: Wed Apr 12, 2006 9:09 am
Location: Norway
Contact:

Re: VFS not writable in VFS writable package

Post by jur » Sun Dec 03, 2017 9:32 pm

A colleague mentioned some issues around PVS and App-V 5. Haven't been troubleshooting around this issue myself but seems to be some info out there. Maybe the Citrix forums.

Are you caching inside the image? If so does it make a difference when using Shared Content Store?
My understanding is that caching on a persistent disk gives a number of issues around permissions.

Sorry on the lack of details, like I said it's second hand info.
Jurjen van Leeuwen
MVP App-V from 2011 to 2016
Application and Desktop Delivery consultant at Leodesk
Norway

Post Reply

Return to “Configuring App-V Client”

Who is online

Users browsing this forum: No registered users and 1 guest