Application not launching

Managing an App-V environment; Check-lists, Tips and Tricks, Best Practices, Videos, How to Guides

Moderators: kirk, jur, kkaminsk

Post Reply
denson
Still installing locally
Posts: 2
Joined: Fri Dec 12, 2014 5:09 pm

Application not launching

Post by denson » Fri Dec 12, 2014 5:32 pm

Hi everybody,

I'm fairly new to packaging and managing App-V and have no colleagues with the right knowledge to help me out, so i'm trying this forum being my 'last resort'.

I have an App-V publishing server running and deploying serveral apps on a citrix (PVS) farm. Since recently one of these apps (A dutch HRM solution) fails to launch. To be more precise the application is synced and mounted correctly, however when a user clicks the launch icon they get the 'hourglass' symbol next to their mouse cursor for a few seconds and then it dissapears and nothing happens. When checking task manager the corresponding process is active and the app-v client tells users the application is 'in use'.

The weird thing is this problem only occurs on appv RDS clients. When i grand myself access on the app and stream the application to my local machine everything works just fine. After all i have tried i have really no idea where to look for the cause of this problem. For all i know the problem might not even be related to App-V, but i just have no idea where to look anymore.

What i have tried so far:

1. Checking (App-V) events. No new App-V errors/warnings are generated when i launch the specific application.
2. I enabled 'Show analytic and debug logs' and started and looked through all App-V related logs (there's alot of them) with nothing worth mentioning
3. Repackaging the application did not change anything
4. Starting the application executable from cache (in my case d:\App-V\packageid\) does not work
5. Starting the application with elevated rights
6. Running procmon shows no odd behavior (allthough i'm no professional)
7. Running the same package from our 'acceptation publishing server' results in the same problem
8. Removing recent OS updates
9. Changing related ACL's to full owner for testing user account
10. Contacting supplier for application debug logging (they claim there is none?!)
11. The application did not have any updates since the problem started
12. There's no applocker in place

Any helpful tips would really be apreciated.

Rorymon
Got AppVirt to work once
Posts: 42
Joined: Wed Jul 28, 2010 1:13 pm
Location: Phoenix, Arizona
Contact:

Re: Application not launching

Post by Rorymon » Fri Dec 12, 2014 6:04 pm

I know you said you already tried it. But ProcMon would be the best tool for this instance. Or you could try SpyStudio...do a trace with it on the local machine and do a trace on RDS and then do a compare. There's a compare option with SpyStudio, it may show at what point the app stops working on RDS which may glean some insight for you.

AlexSweserijnen
Accomplished Virtualizer
Posts: 126
Joined: Tue Mar 31, 2009 10:43 am

Re: Application not launching

Post by AlexSweserijnen » Fri Dec 12, 2014 10:04 pm

We have the exact same behaviour with one of our applications. The infrastructure department suspects the Citrix WDDM driver from causing this problem. Citrix is looking into this problem. Maybe this also causes your application hang.

Another thing to check is if the KB2984972 (https://support.microsoft.com/kb/2984972) is installed on the RDS servers and maybe not on your local machine.

Both are known causes for application hangs.

denson
Still installing locally
Posts: 2
Joined: Fri Dec 12, 2014 5:09 pm

Re: Application not launching

Post by denson » Mon Dec 15, 2014 4:08 pm

@Rorymon
Thank you for your reply. I was not aware of SpyStudio, but it sure looks usefull. Adding it to my toolkit :-)

@Alex
It seems your answer is the fix for my problem (KB update). Apparantly we missed this update because the users claimed problems a week later (note to self: never trust user intel). The weird thing is that it does not show any 'Launching [app name] 100% ' errors in our event viewer.


Thank you both very much, a single post on this forum solved my problem in just a few hours.

Post Reply

Return to “Managing”

Who is online

Users browsing this forum: No registered users and 1 guest