App-V 5.1 office 365 with addons

Managing an App-V environment; Check-lists, Tips and Tricks, Best Practices, Videos, How to Guides

Moderators: kirk, jur, kkaminsk

Post Reply
Mito
Accomplished Virtualizer
Posts: 89
Joined: Mon Dec 22, 2008 11:33 am
Location: Stavanger, Norway

App-V 5.1 office 365 with addons

Post by Mito » Tue Jan 05, 2016 2:44 pm

I have a problem where I am not able to enable a connection group because the VE is in use. The VE in question is the office 365 one. The office package is globally published to the server and seems to always be in use (according to powershell). I am able to use the stop-appvclientpackage command but the VE is fired up again so fast that I am unable to enable the connection group.
Enable-AppvClientConnectionGroup : The operation was successful but at least one of the Virtual Processes in this Connection Group is currently in use. Please shutdown all Virtual Processes in the Connection Group in order to complete this operation.
Tips?

//Thomas

Trentent
Still installing locally
Posts: 5
Joined: Fri Jul 10, 2015 5:36 am

Re: App-V 5.1 office 365 with addons

Post by Trentent » Tue Jan 05, 2016 5:18 pm

If you go to task manager and enable 'Command Line' you should be able to find the offending process by the GUID on the path of the command line. It might give you a hint on what's causing your issue.

Mito
Accomplished Virtualizer
Posts: 89
Joined: Mon Dec 22, 2008 11:33 am
Location: Stavanger, Norway

Re: App-V 5.1 office 365 with addons

Post by Mito » Wed Jan 06, 2016 10:26 am

I found this blog post explaining the issue in depth.

http://blogs.technet.com/b/gladiatormsf ... -mode.aspx

packageologist
Guru
Posts: 244
Joined: Mon Jan 30, 2012 2:58 am
Location: London
Contact:

Re: App-V 5.1 office 365 with addons

Post by packageologist » Wed Jan 06, 2016 11:44 am

My, that's an ugly workaround! :?

Mito
Accomplished Virtualizer
Posts: 89
Joined: Mon Dec 22, 2008 11:33 am
Location: Stavanger, Norway

Re: App-V 5.1 office 365 with addons

Post by Mito » Wed Jan 06, 2016 11:54 am

packageologist wrote:My, that's an ugly workaround! :?
I agree, it seems to me like app-v 5.1 (With connection groups in mind) is not designed for RDS environments.
We are having a lot of CG related issues. I like the feature where, if one package in the CG is bad, all of the packages in the CG stops working.

Tib
Guru
Posts: 219
Joined: Fri Jul 15, 2011 5:06 pm
Location: Belgium

Re: App-V 5.1 office 365 with addons

Post by Tib » Wed Feb 24, 2016 2:00 am

By package is bad, you mean no longer published, or? Did you check the optional checkbox for al those packages in a congroup?
Roy Essers | Tiberivs

Mito
Accomplished Virtualizer
Posts: 89
Joined: Mon Dec 22, 2008 11:33 am
Location: Stavanger, Norway

Re: App-V 5.1 office 365 with addons

Post by Mito » Wed Feb 24, 2016 9:17 am

Say you have 4 packages in a CG, 1 mandatory and 3 optional. Then I create a new package and mess up the com integration settings (since they have to be the same). I publish the package, it works fine, put it in the CG as another optional package and then someone calls because none of the other 4 packages work anymore.

Tib
Guru
Posts: 219
Joined: Fri Jul 15, 2011 5:06 pm
Location: Belgium

Re: App-V 5.1 office 365 with addons

Post by Tib » Wed Feb 24, 2016 4:02 pm

So you are awair of the fact that all packages in a Group need to have the exact same com setting.
Changing the com setting will effect the package, so you have to test first if the package still works. If not, you cant combine them in a Group.
Roy Essers | Tiberivs

Post Reply

Return to “Managing”

Who is online

Users browsing this forum: No registered users and 1 guest