Sequence JRE 8 update 131 x64

Questions, comments, and suggestions for dealing with sequencing specific applications with, and Sequencer 5.0 itself.

Moderators: kirk, jur, kkaminsk

Post Reply
__NeilA__
Still installing locally
Posts: 3
Joined: Mon Apr 03, 2017 4:03 pm

Sequence JRE 8 update 131 x64

Post by __NeilA__ » Wed Jul 12, 2017 12:43 pm

Hi everyone,

I'm currently sequencing Oracle Java Runtime Environment (JRE) v8 update 131 (64-bit) and I'm having trouble getting the virtual package to load JNLP files correctly. When accessing the "https://tex.360t.com/tex.jnlp" URL within IE x64, the result is that the Java splash screen is displayed, with the "Java . . ." progress indicator updating, but the expected logon dialog is never displayed.

Comparing this to the locally installed JRE 8.131, the user logon dialog is displayed, after the standard "Do you want to run this application?" prompt and the "Run" button is selected.

The virtual package successfully navigates to the Java.com verify page and indicates that the correct JRE is installed.

Here's the steps I took to create the virtual package;
Logon to the sequence machine, which is not a member of the domain, as a local admin user
Run the 64-bit powershell program as administrator
Run the "Set-ExecutionPolicy -ExecutionPolicy Bypass" command
Run the ".\jreBlock.ps1 $true" command (see Tim Mangan's blog for more information on this)
Start the sequencer
Run the 64-bit powershell program as administrator
Run the "Set-ExecutionPolicy -ExecutionPolicy Bypass" command
Run the ".\jreBlock.ps1 $false" command
Install JRE using the "msiexec /i jre-8u131-windows-x64.msi /qb AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 ADDLOCAL=ALL" command
Create the "HKLM\Software\JavaSoft\Java Update\Policy\EnableJavaUpdate = 0" dword registry entry
Create the C:\Windows\Sun\Java\Deployment\deployment.config file with the following entries;
deployment.system.config = file:\\C:\\WINDOWS\\Sun\\Java\\Deployment\\deployment.properties
deployment.system.config.mandatory=true
Create the C:\Windows\Sun\Java\Deployment\deployment.properties file with the following entries;
deployment.system.security.trusted.certs=C\:\\Windows\\Sun\\Java\\Deployment\\trusted.certs
deployment.javaws.autodownload=never
deployment.javaws.autodownload.locked
deployment.expiration.check.enabled=false
deployment.expiration.check.enabled.locked
deployment.expiration.decision.suppression=true
deployment.expiration.decision.suppression.locked
deployment.security.level=HIGH
deployment.security.level.locked
deployment.proxy.type=3
deployment.proxy.type.locked
Copy the contents of the %APPDATA%\Sun\Java\Deployment\deployment.properties file and append them to the end of the C:\Windows\Sun\Java\Deployment\deployment.properties file, in this case the entries were;
deployment.modified.timestamp=1499843234430
deployment.roaming.profile=true
deployment.version=8
deployment.browser.path=C\:\\Program Files\\Internet Explorer\\iexplore.exe
deployment.javaws.jre.0.registered=true
deployment.javaws.jre.0.platform=1.8
deployment.javaws.jre.0.osname=Windows
deployment.javaws.jre.0.path=C\:\\Program Files\\Java\\jre1.8.0_131\\bin\\javaw.exe
deployment.javaws.jre.0.product=1.8.0_131
deployment.javaws.jre.0.osarch=amd64
deployment.javaws.jre.0.location=http\://java.sun.com/products/autodl/j2se
deployment.javaws.jre.0.enabled=true
deployment.javaws.jre.0.args=
Run cmd.exe as administrator
Run the "setx deployment.expiration.check.enabled false /m" command

To fix the issue I have tried;
Using Procmon to see if it is failing to find objects or indicating a write permission issue, however there isn't anything that jumps out
Checking all three of the Advanced tab options, e.g. full write permissions to the virtual file system, but this hasn't worked

Platform Information
OS: Windows Server 2012 R2 x64
App-V Sequencer: 5.0.10107.0
App-V Client: 5.0.10107.0

Any help resolving this issue would be gratefully received.

Post Reply

Return to “Sequencing (5.0)”

Who is online

Users browsing this forum: No registered users and 1 guest